re = /Endine nimi\s*<\/td>\s*<td[^>]*>\s*(.*?)\s*<\/td>/
str = 'Endine nimi </td>
<td >
MORENOL OÜ </td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end