using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=GET )([^ ]*)";
string input = @"00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] ""GET /foo/bar/uri.js?id=123 HTTP/1.1"" 200 19165 ""https://nginx.com/foo/bar"" ""Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36"" ""00.00.00.00"" 0.000
00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] ""GET /foo/bar/uri HTTP/1.1"" 200 19165 ""https://nginx.com/foo/bar"" ""Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36"" ""00.00.00.00"" 0.000
00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] ""GET /foo/bar/uri.png HTTP/1.1"" 200 19165 ""https://nginx.com/foo/bar"" ""Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36"" ""00.00.00.00"" 0.000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}