# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=GET )([^ ]*)"
test_str = ("00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] \"GET /foo/bar/uri.js?id=123 HTTP/1.1\" 200 19165 \"https://nginx.com/foo/bar\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36\" \"00.00.00.00\" 0.000\n\n"
"00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] \"GET /foo/bar/uri HTTP/1.1\" 200 19165 \"https://nginx.com/foo/bar\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36\" \"00.00.00.00\" 0.000\n\n"
"00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] \"GET /foo/bar/uri.png HTTP/1.1\" 200 19165 \"https://nginx.com/foo/bar\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36\" \"00.00.00.00\" 0.000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.