import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=GET )([^ ]*)";
final String string = "00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] \"GET /foo/bar/uri.js?id=123 HTTP/1.1\" 200 19165 \"https://nginx.com/foo/bar\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36\" \"00.00.00.00\" 0.000\n\n"
+ "00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] \"GET /foo/bar/uri HTTP/1.1\" 200 19165 \"https://nginx.com/foo/bar\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36\" \"00.00.00.00\" 0.000\n\n"
+ "00.00.00.00 - - [23/Mar/2020:16:23:04 +0000] \"GET /foo/bar/uri.png HTTP/1.1\" 200 19165 \"https://nginx.com/foo/bar\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36\" \"00.00.00.00\" 0.000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}