#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?s)<product>(?=.*?\binstock\b).*?<\/product>)"
Local $sString = "<product><ean_barcode>...</ean_barcode>" & @CRLF & _
"<available>outofstock</available>" & @CRLF & _
"</product>" & @CRLF & _
"<product><ean_barcode>...</ean_barcode>" & @CRLF & _
"<available>instock</available>" & @CRLF & _
"</product>" & @CRLF & _
"<product><ean_barcode>...</ean_barcode>" & @CRLF & _
"<available>outofstock</available>" & @CRLF & _
"</product>" & @CRLF & _
"<product><ean_barcode>...</ean_barcode>" & @CRLF & _
"<available>instock</available>" & @CRLF & _
"</product>" & @CRLF & _
"<product><ean_barcode>...</ean_barcode>" & @CRLF & _
"<available>instock</available>" & @CRLF & _
"</product>" & @CRLF & _
"<product><ean_barcode>...</ean_barcode>" & @CRLF & _
"<available>outofstock</available>" & @CRLF & _
"</product>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")