import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?s)<product>(?=.*?\\binstock\\b).*?<\\/product>)";
final String string = "<product><ean_barcode>...</ean_barcode>\n"
+ "<available>outofstock</available>\n"
+ "</product>\n"
+ "<product><ean_barcode>...</ean_barcode>\n"
+ "<available>instock</available>\n"
+ "</product>\n"
+ "<product><ean_barcode>...</ean_barcode>\n"
+ "<available>outofstock</available>\n"
+ "</product>\n"
+ "<product><ean_barcode>...</ean_barcode>\n"
+ "<available>instock</available>\n"
+ "</product>\n"
+ "<product><ean_barcode>...</ean_barcode>\n"
+ "<available>instock</available>\n"
+ "</product>\n"
+ "<product><ean_barcode>...</ean_barcode>\n"
+ "<available>outofstock</available>\n"
+ "</product>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}