re = /((?s)<product>(?=.*?\binstock\b).*?<\/product>)/m
str = '<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end