#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+)[\n\r](?=^=+$)"
Local $sString = "This is a title" & @CRLF & _
"===============" & @CRLF & _
"" & @CRLF & _
"This is not a title" & @CRLF & _
"" & @CRLF & _
"But this is" & @CRLF & _
"==========="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")