re = /^(.+)[\n\r](?=^=+$)/m
str = 'This is a title
===============
This is not a title
But this is
==========='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end