$re = '~^(.+)[\n\r](?=^=+$)~m';
$str = 'This is a title
===============
This is not a title
But this is
===========';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);