#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-zA-Z0-9]).+"
Local $sString = "asdgfg" & @CRLF & _
"?<>!$!@#" & @CRLF & _
"!@#?d 113" & @CRLF & _
"RBI Square" & @CRLF & _
"123 Mount road" & @CRLF & _
" " & @CRLF & _
".!@#$%^&*()_+|}{[]":';>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")