$re = '/^(?=.*[a-zA-Z0-9]).+/m';
$str = 'asdgfg
?<>!$!@#
!@#?d 113
RBI Square
123 Mount road
.!@#$%^&*()_+|}{[]":\';>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);