re = /^(?=.*[a-zA-Z0-9]).+/m
str = 'asdgfg
?<>!$!@#
!@#?d 113
RBI Square
123 Mount road
.!@#$%^&*()_+|}{[]":\';>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end