import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?>[-+]?[0-9]*\\.?[0-9]+([eE][-+]?[0-9]+)?)\\b";
final String string = "1 this .985 is a1 my test 1a 12 string 12.123 whatever 1 458.785f";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}