$re = '/\b(?>[-+]?[0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?)\b/';
$str = '1 this .985 is a1 my test 1a 12 string 12.123 whatever 1 458.785f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);