import re
regex = re.compile(r"\b(?>[-+]?[0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?)\b")
test_str = "1 this .985 is a1 my test 1a 12 string 12.123 whatever 1 458.785f"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")