const regex = /(\w+)(?:-|\.\w+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)(?:-|\\.\\w+$)', 'gm')
const str = `idss-static-frame.spec`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);