import re
regex = re.compile(r"(\w+)(?:-|\.\w+$)", flags=re.MULTILINE)
test_str = "idss-static-frame.spec"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)