#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!word$).+"
Local $sString = "word" & @CRLF & _
"anywordnow" & @CRLF & _
"anything" & @CRLF & _
"else" & @CRLF & _
"word-workers" & @CRLF & _
"workers-word" & @CRLF & _
"wrodweb" & @CRLF & _
"workers" & @CRLF & _
"exports" & @CRLF & _
"project-explorer"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")