$re = '/^(?!word$).+/m';
$str = 'word
anywordnow
anything
else
word-workers
workers-word
wrodweb
workers
exports
project-explorer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);