using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\p{L}\s]+)\s-.+:([\d\/]*)";
string input = @"Lý Nguyễn Hoàng Ân - Ngày sinh:05/09/2001";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}