re = /([\p{L}\s]+)\s-.+:([\d\/]*)/
str = 'Lý Nguyễn Hoàng Ân - Ngày sinh:05/09/2001'
# Print the match result
str.match(re) do |match|
puts match.to_s
end