package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\p{L}\s]+)\s-.+:([\d\/]*)`)
var str = `Lý Nguyễn Hoàng Ân - Ngày sinh:05/09/2001`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}