package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?) - `)
var str = `206579227 - Account - Account Status Enquiry - [OLUBUSOLA]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}