$re = '/(.*?) - /m';
$str = '206579227 - Account - Account Status Enquiry - [OLUBUSOLA]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);