re = /(.*?) - /m
str = '206579227 - Account - Account Status Enquiry - [OLUBUSOLA]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end