#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^CitrixReceiver\/(0*[1-9]\d\d|0*[2-9]\d|0*19\.0*[1-9]\d\d|0*19\.0*[1-9]\d\d|0*19\.0*[2-9]\d|0*19\.0*1[2-9])"
Local $sString = "CitrixReceiver/0.0.0.0" & @CRLF & _
"CitrixReceiver/9999.9999.0.0" & @CRLF & _
"CitrixReceiver/19.12.0.0" & @CRLF & _
"CitrixReceiver/18.9876.1234.1111" & @CRLF & _
"CitrixReceiver/19.12.999.9999" & @CRLF & _
"CitrixReceiver/19.100.999.9999" & @CRLF & _
"CitrixReceiver/19.000100.999.9999" & @CRLF & _
"CitrixReceiver/00019.00012.0000.0000" & @CRLF & _
"CitrixReceiver/0019.0012.00999.009999" & @CRLF & _
"CitrixReceiver/20.0.0.0" & @CRLF & _
"CitrixReceiver/1.2.3.4" & @CRLF & _
"CitrixReceiver/19.13.3.4" & @CRLF & _
"CitrixReceiver/00019.2.3.4" & @CRLF & _
"CitrixReceiver/000100.2.3.4" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")