import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^CitrixReceiver\\/(0*[1-9]\\d\\d|0*[2-9]\\d|0*19\\.0*[1-9]\\d\\d|0*19\\.0*[1-9]\\d\\d|0*19\\.0*[2-9]\\d|0*19\\.0*1[2-9])";
final String string = "CitrixReceiver/0.0.0.0\n"
+ "CitrixReceiver/9999.9999.0.0\n"
+ "CitrixReceiver/19.12.0.0\n"
+ "CitrixReceiver/18.9876.1234.1111\n"
+ "CitrixReceiver/19.12.999.9999\n"
+ "CitrixReceiver/19.100.999.9999\n"
+ "CitrixReceiver/19.000100.999.9999\n"
+ "CitrixReceiver/00019.00012.0000.0000\n"
+ "CitrixReceiver/0019.0012.00999.009999\n"
+ "CitrixReceiver/20.0.0.0\n"
+ "CitrixReceiver/1.2.3.4\n"
+ "CitrixReceiver/19.13.3.4\n"
+ "CitrixReceiver/00019.2.3.4\n"
+ "CitrixReceiver/000100.2.3.4\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}