using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^CitrixReceiver\/(0*[1-9]\d\d|0*[2-9]\d|0*19\.0*[1-9]\d\d|0*19\.0*[1-9]\d\d|0*19\.0*[2-9]\d|0*19\.0*1[2-9])";
string input = @"CitrixReceiver/0.0.0.0
CitrixReceiver/9999.9999.0.0
CitrixReceiver/19.12.0.0
CitrixReceiver/18.9876.1234.1111
CitrixReceiver/19.12.999.9999
CitrixReceiver/19.100.999.9999
CitrixReceiver/19.000100.999.9999
CitrixReceiver/00019.00012.0000.0000
CitrixReceiver/0019.0012.00999.009999
CitrixReceiver/20.0.0.0
CitrixReceiver/1.2.3.4
CitrixReceiver/19.13.3.4
CitrixReceiver/00019.2.3.4
CitrixReceiver/000100.2.3.4
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}