#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(abc|ABC)[a-zA-Z0-9]{4}$"
Local $sString = "ABCa12d" & @CRLF & _
"abcwed4" & @CRLF & _
"abc1234" & @CRLF & _
"ABCWXYZ" & @CRLF & _
"abcqwerty"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")