package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(abc|ABC)[a-zA-Z0-9]{4}$`)
var str = `ABCa12d
abcwed4
abc1234
ABCWXYZ
abcqwerty`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}