const regex = /^(abc|ABC)[a-zA-Z0-9]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(abc|ABC)[a-zA-Z0-9]{4}$', 'gm')
const str = `ABCa12d
abcwed4
abc1234
ABCWXYZ
abcqwerty`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}