package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(((http|https):)?//?)(lkker-10041312\.file\.myqcloud\.com|lkker-10041312\.cossh\.myqcloud\.com|pic\.lkker\.com|files\.lkker\.com|lkker-10041312\.picsh\.myqcloud\.com|lkker-10041312\.image\.myqcloud\.com|images\.lkker\.com)`)
var str = `http://lkker-10041312.file.myqcloud.com/Images/201712/SrOq15133074890982.png
http://pic.lkker.com/afdsafds
//images.lkker.com/afdsafds
{"A":"//images.lkker.com/afdsafds", "B":"//images.lkker.com/afdsafds"}
//images.lkker.com/afdsafds|https://images.lkker.com/afdsafds|http://images.lkker.com/afdsafds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}