const regex = new RegExp('(((http|https):)?//?)(lkker-10041312\\.file\\.myqcloud\\.com|lkker-10041312\\.cossh\\.myqcloud\\.com|pic\\.lkker\\.com|files\\.lkker\\.com|lkker-10041312\\.picsh\\.myqcloud\\.com|lkker-10041312\\.image\\.myqcloud\\.com|images\\.lkker\\.com)', 'gm')
const str = `http://lkker-10041312.file.myqcloud.com/Images/201712/SrOq15133074890982.png
http://pic.lkker.com/afdsafds
//images.lkker.com/afdsafds
{"A":"//images.lkker.com/afdsafds", "B":"//images.lkker.com/afdsafds"}
//images.lkker.com/afdsafds|https://images.lkker.com/afdsafds|http://images.lkker.com/afdsafds`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}