package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\s\S]*Total:\s*(\d+(?:[,.]\d{1,2})?)`)
var str = `Vat-Total: 123.45
Total: 345.67
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}