// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\s\S]*Total:\s*(\d+(?:[,.]\d{1,2})?)").unwrap();
let string = "Vat-Total: 123.45
Total: 345.67
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}