$re = '/[\s\S]*Total:\s*(\d+(?:[,.]\d{1,2})?)/m';
$str = 'Vat-Total: 123.45
Total: 345.67
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);