using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(post\(['""]\w*).*(\/messages).*[""']{0,1}";
string input = @"post('/messages/new'";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}