$re = '/(post\([\'"]\w*).*(\/messages).*["\']{0,1}/i';
$str = 'post(\'/messages/new\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);