package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(post\(['"]\w*).*(\/messages).*["']{0,1}`)
var str = `post('/messages/new'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}