import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((ltm virtual) ([a-zA-Z0-9_-]*) \\{(.|\\n)*?\\})";
final String string = "Some Garbage text\n"
+ "ltm virtual The_Name_51244_sdfasfdasd {\n"
+ " address-status yes\n"
+ " enabled\n"
+ " fallback-persistence none\n"
+ " profiles {\n"
+ " /Common/GLOBAL_PROFILE {\n"
+ " context all\n"
+ " }\n"
+ " /Common/http {\n"
+ " context all\n"
+ " }\n"
+ " }\n"
+ " rate-class none\n"
+ " rules {\n"
+ " /Common/X-F-F\n"
+ " }\n"
+ " log-profiles none\n"
+ " source-address-translation {\n"
+ " pool SOME-SNAT-POOL\n"
+ " type snat\n"
+ " }\n"
+ " source-port preserve\n"
+ " vlans {\n"
+ " Vlan1111\n"
+ " }\n"
+ " service-down-immediate-action none\n"
+ " service-policy none\n"
+ " source 0.0.0.0/0\n"
+ "}\n"
+ "barbage text\n"
+ "ltm virtual The_Object_51244 {\n"
+ " address-status yes\n"
+ " enabled\n"
+ " fallback-persistence none\n"
+ " profiles {\n"
+ " /Common/GLOBAL_PROFILE {\n"
+ " context all\n"
+ " }\n"
+ " /Common/http {\n"
+ " context all\n"
+ " }\n"
+ " }\n"
+ " rate-class none\n"
+ " rules {\n"
+ " /Common/X-F-F\n"
+ " }\n"
+ " log-profiles none\n"
+ " source-address-translation {\n"
+ " pool SOME-SNAT-POOL\n"
+ " type snat\n"
+ " }\n"
+ " source-port preserve\n"
+ " vlans {\n"
+ " Vlan2222\n"
+ " }\n"
+ " service-down-immediate-action none\n"
+ " service-policy none\n"
+ " source 0.0.0.0/0\n"
+ "}\n"
+ "Trailing garbage text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}