const regex = /((ltm virtual) ([a-zA-Z0-9_-]*) {(.|\n)*?})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((ltm virtual) ([a-zA-Z0-9_-]*) {(.|\\n)*?})', 'gm')
const str = `Some Garbage text
ltm virtual The_Name_51244_sdfasfdasd {
address-status yes
enabled
fallback-persistence none
profiles {
/Common/GLOBAL_PROFILE {
context all
}
/Common/http {
context all
}
}
rate-class none
rules {
/Common/X-F-F
}
log-profiles none
source-address-translation {
pool SOME-SNAT-POOL
type snat
}
source-port preserve
vlans {
Vlan1111
}
service-down-immediate-action none
service-policy none
source 0.0.0.0/0
}
barbage text
ltm virtual The_Object_51244 {
address-status yes
enabled
fallback-persistence none
profiles {
/Common/GLOBAL_PROFILE {
context all
}
/Common/http {
context all
}
}
rate-class none
rules {
/Common/X-F-F
}
log-profiles none
source-address-translation {
pool SOME-SNAT-POOL
type snat
}
source-port preserve
vlans {
Vlan2222
}
service-down-immediate-action none
service-policy none
source 0.0.0.0/0
}
Trailing garbage text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}