# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((ltm virtual) ([a-zA-Z0-9_-]*) {(.|\n)*?})"
test_str = ("Some Garbage text\n"
"ltm virtual The_Name_51244_sdfasfdasd {\n"
" address-status yes\n"
" enabled\n"
" fallback-persistence none\n"
" profiles {\n"
" /Common/GLOBAL_PROFILE {\n"
" context all\n"
" }\n"
" /Common/http {\n"
" context all\n"
" }\n"
" }\n"
" rate-class none\n"
" rules {\n"
" /Common/X-F-F\n"
" }\n"
" log-profiles none\n"
" source-address-translation {\n"
" pool SOME-SNAT-POOL\n"
" type snat\n"
" }\n"
" source-port preserve\n"
" vlans {\n"
" Vlan1111\n"
" }\n"
" service-down-immediate-action none\n"
" service-policy none\n"
" source 0.0.0.0/0\n"
"}\n"
"barbage text\n"
"ltm virtual The_Object_51244 {\n"
" address-status yes\n"
" enabled\n"
" fallback-persistence none\n"
" profiles {\n"
" /Common/GLOBAL_PROFILE {\n"
" context all\n"
" }\n"
" /Common/http {\n"
" context all\n"
" }\n"
" }\n"
" rate-class none\n"
" rules {\n"
" /Common/X-F-F\n"
" }\n"
" log-profiles none\n"
" source-address-translation {\n"
" pool SOME-SNAT-POOL\n"
" type snat\n"
" }\n"
" source-port preserve\n"
" vlans {\n"
" Vlan2222\n"
" }\n"
" service-down-immediate-action none\n"
" service-policy none\n"
" source 0.0.0.0/0\n"
"}\n"
"Trailing garbage text")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.