using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\\\)\/|(?<!\\)\/";
string input = @"aaaa/bbb\/ccc
this/is\/a/\/str\\/ing
aaaa/bbb\\/ccc/ddd\/eee/fff/ggg
aaaa/\bbb
this/is\/a/dumb/str\\/ing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}