import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\\\\\\)\\/|(?<!\\\\)\\/";
final String string = "aaaa/bbb\\/ccc\n"
+ "this/is\\/a/\\/str\\\\/ing\n"
+ "aaaa/bbb\\\\/ccc/ddd\\/eee/fff/ggg\n"
+ "aaaa/\\bbb\n"
+ "this/is\\/a/dumb/str\\\\/ing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}