re = /(?<=\\\\)\/|(?<!\\)\//m
str = 'aaaa/bbb\\/ccc
this/is\\/a/\\/str\\\\/ing
aaaa/bbb\\\\/ccc/ddd\\/eee/fff/ggg
aaaa/\\bbb
this/is\\/a/dumb/str\\\\/ing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end