package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^browse/(coffee|goodies)/([A-Za-z0-9\%\+\-]+)/([0-9]+)/?`)
var str = `browse/goodies/Books+%26+DVDs/3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}