const regex = new RegExp('^browse/(coffee|goodies)/([A-Za-z0-9\\%\\+\\-]+)/([0-9]+)/?', 'gm')
const str = `browse/goodies/Books+%26+DVDs/3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}