using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^systemstatus get (?!resume(?:\s|$)).*$";
string input = @"systemstatus get resume
systemstatus get idle
systemstatus get talking
systemstatus get ringing
systemstatus get outgoing
systemstatus get sleeping
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}