re = /^systemstatus get (?!resume(?:\s|$)).*$/m
str = 'systemstatus get resume
systemstatus get idle
systemstatus get talking
systemstatus get ringing
systemstatus get outgoing
systemstatus get sleeping
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end